miércoles, agosto 02, 2006

Crear Función en EXCEL


PASOS A SEGUIR PARA CREAR UNA FUNCION EN EXCEL

1. Seleccionar Tools-->Visual Basic Editor
2. Una vez abierto el editor seleccionar Insert-->Module
3. Aparecerá una ventana para editar, introducir el siguiente código:

Function HolaMundo(mayusculas As Integer) As String
If mayusculas > 0 Then
HolaMundo = "HOLA MUNDO"
Else
HolaMundo = "hola mundo"
End If
End Function

4. Regresar a la hoja de Excel e introducir en cualquier celda lo siguiente:

=holamundo(1)

Si todo va bien veras HOLA MUNDO. Ahora introduce lo siguiente:

=holamundo(0)

Ahora veras hola mundo.

Descarga aqui la hoja de Excel si quieres evitar seguir todos los anteriores pasos.


12 comentarios:

GemMaths dijo...

Hola José,
a muchos les parecerá inútil la función que has puesto, pero por simple que parezca lleva solo un pequeño ápice del mundo de la programación.
Espero que sigas mostrándonos de esto y mucho más a menudo.

José dijo...

Basicamente me enfoque a contestar una simple pregunta y asumiendo que el mundo está lleno de impacientes (yo lo soy).

Aunque hay excelentes tutoriales para crear funciones, he observado que el impaciente (incluyendome yo) se pierde de ellos por evita leer los 2 primero párrafos y con eso en mente lo hice.

Muchas gracias por tus comentarios Gemmaths.

Gemuina dijo...

Pero sigue actualizando que es un espacio interesante José y no lo dejes por pereza. Este es el nuevo nick del otro blog que tengo, pero ese ya no hablo generalmente de Matemáticas.
Soy GemMaths

Walter dijo...

Hola:
Estuvo muy didáctico tu ejemplo. Me ha servido para mis clases.
Gracias por el aporte.
Saludos Walter

Daniel dijo...

Muy buena la explicación. Tengo un gran problema en excel, necesito buscar unos numeros correspondiente a cierto codigo, el problema que el codigo se repite muchas veces y buscarv()solo encuentra el primero. Necesito encontrar todos los valores asociados a un codigo y sumarlos. Como lo podre hacer??

José dijo...

Daniel:

En lugar de buscarsv puedes usar algo como esto: =SI(A1=codigo_buscado;codigo_buscado;0)

copias esta formula varias veces en la misma posición y al final lo sumas. En caso que no haya quedado claro subí el archivo aquí, espero te sea de utilidad.

Felipe dijo...

quiza la funcio sumar.si sea más útil

hernan dijo...

Excelente ejemplo, alguien que sepa de programación, inmediatamente se encamina...

Gracias por todo....

Anónimo dijo...

yo quiero esto:

TAG QTY
1F1 2
1F2 2


y quede asi

TAG QTY
1F1-1 1
1F1-2 1
1S2-1 1
1S2-2 1

Necesito hacer esto para una lista muy extensa..gracias

Adolfo Rios Mixco dijo...

Excelente comentario, busque en muchos foros y aunque sencillo encontre justo lo que andaba buscando.

Adolfo Rios Mixco dijo...

Muy buen aporte sencillo pero encontre justo lo que necesitaba, yo tambien soy uno de esos impacientes como lo dices. jaja

Anónimo dijo...

berto13El problema de Daniel del Buscarv se puede solucionar concatenando algo mas que haga único el código, como por ejemplo: Los números de teléfonos se pueden repetir en mas de una región pero de concateno el código de área, esto hace que ese número repetido se haga único.